17.11.2020

Zählen: Werte in Excel zählen

Wie Sie Werte aufgrund bestimmer Eigenschaften in Excel zählen können, lesen Sie in diesem Beitrag.

Von: Frédéric Jordan  DruckenTeilen 

Frédéric Jordan

Frédéric Jordan ist dipl. Experte in Organisationsmanagement und als Organisations- und Managementberater bei Jordan Consulting tätig.

Zählen

Funktion =Zählenwenn() und Zählenwenns()

Beides sind statistische Funktionen, um die Anzahl der Zellen zu zählen, die das vordefinierte Kriterium erfüllt. Der Unterschied liegt dabei darin, dass im ersten Fall die nicht leeren Zellen eines Bereichs gezählt werden, deren Inhalte mit den Suchkriterien übereinstimmen. Bedeutet: Ermittelt die Anzahl der Zellen mit dem Wert "x". Bei =Zählenwenns() wird die reine Anzahl der Zellen ausgegeben, welche die Bedingung erfüllen.

Zählenwenn

Syntax

=ZÄHLENWENN (Wo möchten Sie suchen? Wonach möchten Sie suchen?)

Zählenwenns

Syntax

ZÄHLENWENNS (Kriterienbereich1;Kriterien1;[Kriterienbereich2; Kriterien2] …)

Die Syntax der Funktion ZÄHLENWENNS weist die folgenden Argumente auf:

  • <c0>Kriterienbereich1</c0>
    Erforderlich. Der erste Bereich, in dem die zugehörigen Kriterien ausgewertet werden sollen.
  • <c0>Kriterien1</c0>
    Erforderlich. Die Kriterien in Form einer Zahl, eines Ausdrucks, Zellbezugs oder Texts, mit denen definiert wird, welche Zellen gezählt werden. Kriterien können beispielsweise als 32, ">32", B4, "Äpfel" oder "32" angegeben werden.
  • <c0>Kriterienbereich2;Kriterien2; …</c0>
    Optional. Zusätzliche Bereiche und deren zugehörige Kriterien. Es sind bis zu 127 Bereich-Kriterien-Paare zulässig. 

Beispiel:
   
Erhalten Sie anhand dieser drei nachfolgenden Abbildungen ein Einblick in ein Beispiel:
    – Abbildung 1
    – Abbildung 2
    – Abbildung 3

Häufige Probleme

Häufige ProblemeUrsache
Für lange Zeichenfolgen wird ein falscher
Wert zurückgegeben.

Die Funktion ZÄHLENWENN gibt falsche Ergebnisse zurück, wenn sie dazu verwendet wird,
Zeichenfolgen mit mehr als 255 Zeichen abzugleichen.

Um Zeichenfolgen mit mehr als 255 Zeichen abzugleichen, verwenden Sie die Funktion VERKETTEN
oder den Verkettungsoperator &. Beispiel: = ZÄHLENWENN(A2:A5;"lange Zeichenfolge"&"weitere lange Zeichenfolge").
Es wird kein Wert zurückgegeben,
obwohl Sie einen Wert erwarten.
Stellen Sie sicher, dass das Kriterien-Argument in Anführungszeichen angegeben ist.
Eine ZÄHLENWENN-Formel erhält eine #VALUE!
Fehler beim Verweisen auf ein anderes Arbeitsblatt.
Dieser Fehler tritt auf, wenn die Formel mit der Funktion auf Zellen oder einen Bereich
in einer geschlossenen Arbeitsmappe verweist und die Zellen berechnet werden.
Damit dieses Feature funktioniert, muss die andere Arbeitsmappe geöffnet sein.

Bewährte Methoden und Lösungsansätze

AktionGrund
Beachten Sie, dass ZÄHLENWENN Gross- und Kleinschreibung in Zeichenfolgen ignoriert.Bei Suchkriterien wird die Gross- und Kleinschreibung nicht beachtet. Das bedeutet,
mit den Zeichenfolgen "äpfel" und "ÄPFEL" werden dieselben Zellen einbezogen.
Verwenden Sie Platzhalterzeichen.

Platzhalterzeichen – das Fragezeichen (?) und das Sternchen (*) – können in Kriterien
verwendet werden. Ein Fragezeichen ersetzt ein einzelnes Zeichen. Ein Sternchen ersetzt
eine beliebige Zeichenfolge. Wenn Sie nach einem tatsächlichen Fragezeichen oder Sternchen
suchen möchten, geben Sie vor dem Zeichen eine Tilde (~) ein.

Beispiel: =ZÄHLENWENN(A2:A5;"apfel?") ermittelt alle Instanzen von "apfel", wobei
der letzte Buchstabe variieren kann.
Stellen Sie sicher, dass Ihre Daten keine fehlerhaften Zeichen enthalten.

Beim Zählen von Textwerten müssen Sie sicherstellen, dass die Daten keine führenden
oder abschliessenden Leerzeichen enthalten, dass gerade und typografische Anführungszeichen
nicht inkonsistent verwendet wurden und dass keine nicht druckbaren Zeichen vorhanden sind.
In diesen Fällen gibt ZÄHLENWENN möglicherweise einen unerwarteten Wert zurück.

Verwenden Sie die Funktion SÄUBERN oder GLÄTTEN.
Verwenden Sie zur einfacheren Handhabung benannte Bereiche.ZÄHLENWENN unterstützt benannte Bereiche in einer Formel (z.B. =ZÄHLENWENN (Obst;">=32")-ZÄHLENWENN (Obst;">85").
Der benannte Bereich kann sich im aktuellen Arbeitsblatt, in einem anderen Arbeitsblatt in
derselben Arbeitsmappe oder in einer anderen Arbeitsmappe befinden. Wenn aus einer
anderen Arbeitsmappe darauf verwiesen werden soll, muss diese zweite Arbeitsmappe
ebenfalls geöffnet sein.

 

Produkt-Empfehlungen

  • Planung & Unternehmenssteuerung

    Planung & Unternehmenssteuerung

    Das Controlling-Cockpit für die erfolgreiche Planung und Steuerung.

    ab CHF 168.00

  • Controlling mit Excel

    Controlling mit Excel

    Schluss mit Excel-Frust im Controlling, dank über 1600 fertigen Vorlagen.

    Mehr Infos

  • Finance Professional

    Finance Professional

    Die Komplettlösung für Ihr Rechnungswesen und Controlling.

    Mehr Infos

Seminar-Empfehlungen

  • Praxis-Seminar, 1 Tag, ZWB, Zürich

    Excel-Training für Rechnungswesen und Controlling - Basic

    Modelle optimal gestalten und Daten nach Excel importieren

    Nächster Termin: 09. Dezember 2020

    mehr Infos

  • Praxis-Seminar, 1 Tag, ZWB, Zürich

    Excel-Training für Rechnungswesen und Controlling - Advanced

    Daten anschaulich visualisieren und professionelle Prognosen erstellen

    Nächster Termin: 10. Dezember 2020

    mehr Infos

  • Praxis-Seminar, 1 Tag, SIB, Zürich

    Excel-Training für Rechnungswesen und Controlling - Professional

    Interaktive Management-Cockpits mit Excel erstellen

    Nächster Termin: 31. März 2021

    mehr Infos

Um unsere Website laufend zu verbessern, verwenden wir Cookies. Durch die Nutzung dieser Website stimmen Sie der Verwendung von Cookies zu. Mehr Infos