20.08.2018

SVERWEIS: Automatische Wertesuche in Excel mit mehreren Kriterien

Die Funktion SVERWEIS eignet sich hervorragend, wenn es darum geht, bestimmte Inhalte einer Tabelle auszulesen. Leider hat die Suchfunktion eine zentrale Einschränkung: Mit SVERWEIS können nur Suchbegriffe in einer einzigen Spalte gesucht werden. Befinden sich die Suchbegriffe aber in 2 oder mehr Spalten, so muss die Suche über eine andere Funktionalität durchgeführt werden. Das kann beispielsweise über eine geschachtelte WENN-Abfrage gelöst werden oder auf elegantere Art in Kombination mit der Funktion WAHL. Die letztgenannte Variante lernen Sie in diesem Beitrag kennen. Anhand der Musterlösungsdatei können Sie Arbeitsschritte nachvollziehen

Von: Frédéric Jordan  DruckenTeilen Kommentieren 

Frédéric Jordan

Frédéric Jordan ist dipl. Experte in Organisationsmanagement und als Organisations- und Managementberater bei Jordan Consulting tätig.

Zu diesem Artikel wurden noch keine Kommentare geschrieben. Wir freuen uns, wenn Sie den ersten Kommentar zu diesem Artikel verfassen.
 
Kommentar schreiben

Bitte Wert angeben!

Bitte Wert angeben!

Bitte Wert angeben! Bitte geben Sie eine gültige E-Mail-Adresse ein!

Bitte Wert angeben!

Bitte Wert angeben!

Bitte Wert angeben!

Bitte alle fett beschrifteten Pflichtfelder ausfüllen.
Zurücksetzen
 

Die Funktion SVERWEIS für einfache Suchanfragen

In der Beispieltabelle mit Baumarkt-Artikeln soll nach dem Preis für einen beliebigen Artikel aus dem Sortiment gesucht werden. Zu diesem Zweck setzen Sie die Funktion SVERWEIS ein.

Step by Step
Suche mit der Funktion SVERWEIS

  1. Geben Sie in der Zelle E4 die Artikelbezeichnung für den Artikel ein, dessen Preis Sie suchen.
  2. Setzen Sie anschließend den Mauszeiger in die Zelle F4 und geben Sie dort folgende Formel ein: =SVERWEIS(E4;A4:B15;2;0)
  3. Sie erhalten den Einkaufspreis des Artikels angezeigt.

Abbildung 1: So sieht die einfache Suche mit SVERWEIS aus.

Die Suche mit mehreren Kriterien mit der Funktion WAHL

Komplizierter wird die Suche, wenn Sie in mehreren Spalten und nach mehreren Kriterien suchen möchten. Wie bereits erwähnt, können Sie das mit Hilfe verschachtelter WENN-Abfragen lösen. Oder aber Sie kombinieren die Funktion SVERWEIS mit der Funktion WAHL, um ein Suchargument über mehrere Spalten zu erstellen. In der erweiterten Tabelle sollen nun die Preise für kombinierte Artikel aus den Spalten 1 und 2 ermittelt werden.

Abbildung 2: Jetzt werden 2 Kriterien für die Auswahl herangezogen.

Die Funktion WAHL wird für das Argument der Matrix innerhalb der Funktion SVERWEIS wie folgt zusammengesetzt: WAHL({1.2};A4:A14&B4:B14;C4:C14)

Die geschweiften Klammern für den zusammengesetzten Spaltenindex 1.2 werden über die Tastatur eingegeben (nicht wie am Ende der Matrixfunktion).

Step by Step
Suche mit der Funktion SVERWEIS kombiniert mit WAHL

  1. Geben Sie in der Zelle E4 und F4 die Artikelbezeichnungen für den Artikel ein, dessen Preis Sie suchen.
  2. In Zelle G4 geben Sie dann die gesamte Formel wie folgt ein:
  3. =SVERWEIS(E4&F4;WAHL({1.2};A4:A14&B4:B14;C4:C14);2;0)
  4. Erstellen Sie am Ende die geschweiften Klammern für die Matrixfunktion mit der Tastenkombination Strg + Shift + Enter.
  5. Sie bekommen den Einkaufspreis des Artikels angezeigt.

Abbildung 3: Die Kombination von SVERWEIS und WAHL findet den gewünschten Eintrag.

Sie können mit dieser Vorgehensweise die Anzahl der Spalten und Kriterien jederzeit noch erweitern.

Seminar-Empfehlung

Praxis-Seminar, 1 Tag, ZWB, Zürich

Excel-Training für Rechnungswesen und Controlling - Advanced

Daten anschaulich visualisieren und professionelle Prognosen erstellen

Nächster Termin: 28. November 2018

mehr Infos

Produkt-Empfehlungen

  • Top-Tools für erfolgreiches Controlling

    Top-Tools für erfolgreiches Controlling

    Über 50 Excel-Rechner und Analyse-Tools

    CHF 148.00

  • Excel im Unternehmen

    Excel im Unternehmen

    Sparen Sie Zeit und Kosten mit professionellen Excel-Lösungen für die Unternehmens-Praxis

    Mehr Infos

  • Controlling mit Excel

    Controlling mit Excel

    Schluss mit Excel-Frust im Controlling, dank über 1600 fertigen Vorlagen.

    Mehr Infos

Seminar-Empfehlungen

  • Praxis-Seminar, 1 Tag, ZWB, Zürich

    Excel-Training für Rechnungswesen und Controlling - Basic

    Modelle optimal gestalten und Daten nach Excel importieren

    Nächster Termin: 27. November 2018

    mehr Infos

  • Praxis-Seminar, 1 Tag, ZWB, Zürich

    Excel-Training für Rechnungswesen und Controlling - Advanced

    Daten anschaulich visualisieren und professionelle Prognosen erstellen

    Nächster Termin: 28. November 2018

    mehr Infos

  • Praxis-Seminar, 1 Tag, ZWB, Zürich

    Excel-Training für Rechnungswesen und Controlling - Professional

    Interaktive Management-Cockpits mit Excel erstellen

    Nächster Termin: 28. März 2019

    mehr Infos

Um unsere Website laufend zu verbessern, verwenden wir Cookies. Durch die Nutzung dieser Website stimmen Sie der Verwendung von Cookies zu. Mehr Infos